Ir al contenido principal

Web Hosting y WordPress Hosting — Solucionar el error 504 Gateway Timeout

L
Escrito por Luciana Parente

Aplica a: Web Hosting y WordPress Hosting · Tiempo estimado: variable


¿Qué vas a lograr?

Identificar la causa del error 504 Gateway Timeout y aplicar la solución correspondiente para restaurar el acceso al sitio.


Qué es el error 504

El error 504 indica que el servidor no recibió una respuesta a tiempo de otro servidor. A diferencia del error 500, suele estar relacionado con tiempos de espera agotados más que con errores de configuración. Aparece con mensajes como "Gateway Timeout", "504 Error" o "The server didn't respond in time".


Error 504 gateway timeout: variaciones y causas

Si recibís el error 504 Bad Gateway, se suele ver algo así:

Este error HTTP también puede aparecer en una variedad de formas y con múltiples mensajes de error en varios navegadores, servidores y sistemas operativos. Estos son las más frecuentes:

  • 504 Gateway Timeout nginx

  • Gateway Timeout Error

  • Gateway Timeout (504)

  • HTTP Error 504

  • Error 504

  • 504 Error

  • 504 Gateway Timeout – The server didn’t respond in time

  • This page isn’t working. Domain took too long to respond

  • HTTP Error 504 – Gateway Timeout

  • 504 Status Code

  • 504 Error Code

El primer paso para solucionar el error 504 Gateway Timeout es descubrir las causas. Estos son algunos de los problemas que pueden provocar este error:

  • Problemas con el firewall. Algunos firewalls tienen sistemas de protección y mitigación de DDoS que pueden bloquear las solicitudes de proveedores de servicios de Internet o redes de distribución de contenidos como Cloudflare. La configuración del firewall defectuosa también puede ser el problema.

  • Dominio sin solucionar. Esto ocurre cuando un dominio no se resuelve correctamente a una dirección IP. Este problema puede surgir cuando un sitio web ha cambiado de dirección IP o nameserver.

  • Problemas con la conectividad. Es posible que tu dispositivo de red esté experimentando problemas temporales de conexión si el error 504 Gateway Timeout aparece en una variedad de navegadores, dispositivos o sitios web.

  • Carga excesiva del servidor web. Un servidor web con recursos limitados puede sobrecargarse y responder a las peticiones del navegador con retraso, agotando el tiempo de espera del otro servidor.

  • Workers de PHP limitados. Estos componentes administran las peticiones cada vez que un usuario hace algo en un sitio web de WordPress. Al procesar varias solicitudes, tu sitio web puede fallar si no tenés suficientes workers de PHP.

  • Problemas con el sistema de nombres de dominio (DNS). Estos incluyen configuraciones DNS incorrectas y cachés DNS obsoletos o corruptos.


Soluciones en orden de probabilidad

Los errores 504 generalmente se originan en el lado del servidor. Sin embargo, también pueden aparecer como resultado de problemas o configuraciones incorrectas del cliente.

Teniendo en cuenta ambas opciones, repasaremos los pasos básicos para solucionar el problema. La mayoría de las soluciones funcionan con cualquier sitio web, pero algunas son especiales para WordPress.
​

1. Actualizar el sitio web

Este consejo puede parecer sencillo, pero es una de las soluciones más comunes para resolver el error 504 gateway timeout. Es posible que el servidor esté recibiendo más solicitudes de lo normal, por lo que es posible que sea útil refrescar la página.

La manera más sencilla de hacerlo es pulsar F5 o hacer clic en el botón Actualizar junto a la barra de direcciones del navegador. Además, para forzar la actualización de la página y borrar la caché del navegador, pulsá Ctrl + F5.

Comprobá si el sitio web está caído mientras esperás a que se actualice la página. Esto determinará si el problema se encuentra en la red local.

2. Revisá cómo se utiliza el pedido.

Cada plan de hosting proporciona una cantidad específica de recursos para maximizar el rendimiento del sitio web. Los usuarios de DonWeb pueden acceder al menú de uso de recursos en Ferozo para ver los recursos que te han sido asignados.

Los usuarios verán un mensaje de error del servidor si tu sitio de WordPress ha alcanzado los límites del plan de alojamiento. Si este es el caso, consultá con tu proveedor de alojamiento para actualizar a un plan que incluya más recursos para satisfacer las necesidades de tu sitio.

Aumentar el límite máximo de tiempo de ejecución de PHP es otra posible solución a este problema. Cuando los scripts de PHP tardan más en completarse que el tiempo predeterminado, puede haber tiempos de espera del servidor.

Aumentar el límite de tiempo máximo de ejecución ayudará a evitar que los script se marquen como un error a mitad del proceso. Para lograrlo, editá manualmente el archivo .htaccess, instalá el complemento Google Pagespeed Insights o modificá la configuración de PHP utilizando el panel de control de tu cuenta de hosting.

Para aumentar el valor máximo de ejecución de tiempo (max-execution-time) de WordPress a través de Ferozo, seguí estos pasos:

  1. En la sección principal de Ferozo, dirigite a Mi Sitio Web y luego a Configuración de PHP

  2. En Opciones de PHP, desplazate hacia abajo hasta encontrar el campo max_execution_time

  3. El valor predeterminado es de treinta segundos. Hacé clic en Guardar después de ajustarlo a 60. Si eso no ayuda, aumentá a 120 a 180 segundos.

3. Experimentá con un navegador alternativo

Si al actualizar la página y aumentar el límite de tiempo máximo de ejecución de los scripts PHP no se ha resuelto el error 504 gateway timeout, el problema puede estar relacionado con el navegador.

Para asegurarse de que no sea un error del lado del servidor, intentá cargar el sitio de WordPress en otro navegador utilizando el modo de incógnito. Borrar la caché del navegador antes de recargar la página también acelerará el tiempo de carga de la página y reducirá la probabilidad de que el servidor tenga que esperar.

4. Actualizar y renovar la caché DNS

Los problemas de DNS pueden surgir tanto en el servidor como en el cliente. Los del lado del servidor suelen ocurrir en sitios web con direcciones IP no resueltas, mientras que los del lado del cliente son causados por una caché de DNS obsoleta o corrupta.

Si el sitio web de WordPress se migró recientemente a un nuevo dominio o servidor, es posible que la modificación no haya terminado de extenderse por todo el mundo. La propagación de DNS tarda entre 24 y 48 horas en completarse, por lo que necesitás un comprobador de propagación de DNS para ver si el proceso se ha completado.

Para solucionar los problemas de DNS del lado del cliente, intentá vaciar tu caché DNS. El sistema operativo mantiene una caché local, al igual que los navegadores. El vaciado de DNS eliminará los archivos de caché dañados y obsoletos que podrían causar errores.

La forma de hacerlo varía según el sistema operativo. Por ejemplo, los pasos que deben seguirse para vaciar la caché DNS en Microsoft Windows son:

  1. Para abrir la línea de comandos, presioná simultáneamente las teclas Windows + R y escribí cmd

  2. Para borrar los archivos de caché DNS y restablecer la caché del resolutor DNS, escribí ipconfig /flushdns y luego presioná enter

  3. Si el proceso se completó correctamente, aparecerá un mensaje de confirmación como el siguiente

Una excelente manera de eliminar la posibilidad de un problema DNS es cambiar temporalmente el servidor DNS por uno público. Cloudflare 1.1.1.1, Google Public DNS y Comodo Secure DNS son algunos de los servidores DNS públicos más populares.

5. Experimentá con varios dispositivos

Intentá cargar la página web en una computadora, una red o un teléfono móvil diferente. Además, podés probar reiniciar los dispositivos de red para ver si hay un problema de hardware o de conexión a internet.

Si el error 504 aparece en varios dispositivos, es probable que sea un problema del servidor.

6. Verificá el archivo de errores

Los cambios o actualizaciones recientes en el sitio web también pueden causar el error 504 gateway timeout. La forma más rápida de descubrirlo es revisando el registro de errores.

Para activar la función de registro de errores, podés revisar nuestra guía específica haciendo clic aquí.

7. Revisar los plugins de nuestro sitio

A menudo, un plugin de WordPress puede causar el error 504. Algunos plugins, particularmente los relacionados con el almacenamiento en caché, envían peticiones al servidor, lo que aumenta la carga de los workers de PHP, lo que puede causar el problema.

Los plugins también pueden causar problemas. Desactivar temporalmente cada uno de ellos te ayudará a encontrar un plugin defectuoso.

Visitá el directorio wp-content y cambiá el nombre de la carpeta de plugins. Esto desactivará todos los plugins de WordPress que tengas instalados. Podés usar el Administrador de archivos de tu cuenta de hosting o FileZilla, un cliente FTP.

Si tu sitio web funciona correctamente cuando todos los plugins están deshabilitados, lo siguiente es determinar qué plugin está causando el error. Para encontrar el origen del problema, restaurá el nombre original del directorio de plugins y desactivá todos los plugins uno por uno.

8. Verificá CDNs

Si la utilizás, podés comprobar si una red de distribución de contenidos (CDN) funciona correctamente.

CloudFlare, que también sirve como servicio de mitigación de DDoS, es uno de los CDN más populares. Podés encontrar dos versiones del error 504 al usarlo.

Si el mensaje de error menciona a CloudFlare, el problema se origina en ese lugar. Podés ver el estado del sistema de Cloudflare para ver si la empresa está al tanto de algún problema de red.

La forma más rápida de resolver el problema en este caso es ponerse en contacto con el soporte de CloudFlare. De lo contrario, desactivá por completo la CDN y esperá hasta que se propague por completo el DNS.

Según esta versión de la página de error 504, el proveedor de alojamiento web es responsable del problema, y debés contactarlo para obtener ayuda.

9. Configuración del servidor

En los sitios web con VPS hosting, los problemas del servidor web son una causa común del error 504 gateway timeout.

El límite de tiempo de ejecución de los scripts PHP puede causar un error si estás usando el servidor web Apache.

Un límite en el tiempo de conexión del proxy en los sitios web que se ejecutan sobre Nginx es la causa más común del error 504.

En las siguientes secciones, discutiremos cómo ajustar la configuración del servidor y aumentar los límites de recursos específicos para resolver el error 504 en ambas plataformas.

Apache

Los usuarios de Apache pueden aumentar el valor predeterminado de tiempo de espera en el archivo httpd.conf. Para aumentar el valor del tiempo de espera por defecto de 300 a 600 segundos, agregá la siguiente línea al archivo de configuración de Apache:

Timeout 600

El nuevo valor obligará al servidor a esperar la petición más tiempo antes de que se agote el tiempo de ejecución.

Para que los scripts PHP se ejecuten durante más tiempo, también podés aumentar el límite de max_execution_time en php.ini:

max_execution_time 300

Reiniciá Apache después de guardar los cambios. Si la causa del error 504 era un tiempo de espera insuficiente, debería haber desaparecido.

Nginx

Si tu VPS utiliza Nginx como proxy inverso para Apache, intentá aumentar los valores siguientes en /etc/nginx/conf.d/timeout.conf:

proxy_connect_timeout 600; 
proxy_send_timeout 600;
proxy_read_timeout 600;
send_timeout 600;

Si usás Nginx con el Manejador de Procesos FastCGI (PHP-FPM), debés editar el archivo PHP-FPM. Abrí el archivo /etc/php5/fpm/pool.d/www.conf y agregá la línea siguiente:

Request_terminate_timeout = 300

Aumentar max_execution_time en php.ini también es recomendable:

max_execution_time 300

Observá las modificaciones, reiniciá Nginx y recargá el sitio web.

10. Contactá al servicio de atención al cliente

Es aconsejable comunicarse con el personal de soporte del hosting web en caso de que persista el error 504 gateway timeout después de intentar todas las soluciones anteriores. Para acelerar el proceso, proporcioná tanta información como sea posible y describí las soluciones que intentaste para resolver el problema.


📍Conclusiones

Uno de los códigos de estado HTTP más comunes que encuentran los usuarios de internet es el error 504 gateway timeout. A pesar de que el mensaje de error contiene poca información sobre el origen del problema, hay varias formas de resolverlo.

Aquí hay un resumen de las diez soluciones potenciales al error 504:

  • Actualizar el sitio web.

  • Verificar la utilización del pedido de hosting.

  • Abrir la página en un navegador diferente.

  • Eliminando la caché de DNS.

  • Abrir la página en varios dispositivos y reiniciar toda la red.

  • Examinar el registro de errores para encontrar códigos defectuosos y configuraciones erróneas.

  • Revisar los plugins que se han instalado.

  • Verificar el estado del CDN.

  • Comprobar la configuración de Apache o Nginx para resolver los problemas de conectividad del servidor.

  • Ponerte en contacto con el equipo de soporte de tu proveedor.


¿Ha quedado contestada tu pregunta?